Fax to Email Service

Incident Report for SIP US

Resolved

We have identified and resolved the issue and have conducted multiple tests confirming that the Fax‑to‑Email service is fully operational and restored.
Posted Apr 24, 2026 - 20:01 EDT

Update

We are continuing to investigate this issue.
Posted Apr 24, 2026 - 20:01 EDT

Investigating

We are currently investigating an issue with the fax-to-email service
Posted Apr 24, 2026 - 16:11 EDT
This incident affected: Fax Service.